Daftar Radius Attribute Netlayer

Pengenalan Radius Attribute

Radius (Remote Authentication Dial-In User Service) merupakan protokol AAA (Authentication, Authorization, dan Accounting) yang digunakan untuk mengelola akses pengguna ke jaringan. Komunikasi antara NAS (Network Access Server) dan server Radius dilakukan melalui pertukaran paket yang berisi kumpulan attribute.

Setiap attribute memiliki format Type-Length-Value (TLV) dengan struktur sebagai berikut:

Attribute digunakan baik pada paket Access-Request, Access-Accept, Access-Reject, Accounting-Request, maupun Accounting-Response. Sebagian attribute bersifat wajib (seperti User-Name dan User-Password), sementara sebagian lainnya bersifat opsional.

Attribute Standard RFC

Attribute standard didefinisikan oleh IETF melalui serangkaian RFC, antara lain RFC 2865 (Authentication & Authorization), RFC 2866 (Accounting), RFC 2867 (Tunnel Protocol Support), RFC 2868 (Tunnel Protocol Support for AAA), RFC 3162 (IPv6), RFC 3576 (Dynamic Authorization), RFC 5090 (Digest Authentication), dan beberapa RFC lainnya. Attribute-attribute ini memiliki nomor Type di bawah 256 dan berlaku universal untuk semua implementasi Radius.

Tipe data yang umum digunakan pada attribute standard meliputi:

Vendor-Specific Attribute (VSA)

Selain attribute standard, Radius juga mendukung Vendor-Specific Attribute (VSA) yang didefinisikan pada RFC 2865 bagian 5.26. VSA memungkinkan vendor perangkat jaringan menambahkan attribute sendiri tanpa harus mengubah standar RFC, dengan cara mengenkapsulasi attribute dalam attribute Vendor-Specific (Type 26).

Format VSA terdiri dari:

Sebagai contoh, MikroTik memiliki Vendor-Id 14988, Microsoft memiliki Vendor-Id 311, Cisco memiliki Vendor-Id 9, dan ZTE memiliki Vendor-Id 3902. Vendor lain seperti Juniper (2636), Huawei (2011), dan Nokia (6527) juga memiliki Vendor-Id masing-masing dengan kumpulan attribute sendiri[citation:11][citation:12].

Daftar Attribute

Berikut ini adalah daftar Radius Attribute yang sudah terdaftar di server Radius Netlayer. Jika Anda ingin mendaftarkan attribute khusus yang Anda butuhkan, silakan hubungi admin.

Standard RFC

Name ID Type
User-Name1string
User-Password2string
CHAP-Password3string
NAS-IP-Address4ip_address
NAS-Port5uint32
Service-Type6uint32
Framed-Protocol7uint32
Framed-IP-Address8ip_address
Framed-IP-Netmask9ip_address
Framed-Routing10uint32
Filter-Id11string
Framed-MTU12uint32
Framed-Compression13uint32
Login-IP-Host14ip_address
Login-Service15uint32
Login-TCP-Port16uint32
Framed-IPX-Address17string
Reply-Message18string
Callback-Number19string
Callback-Id20string
Framed-Route22string
Framed-IPX-Network23uint32
State24string
Class25string
Vendor-Specific26string
Session-Timeout27uint32
Idle-Timeout28uint32
Termination-Action29uint32
Called-Station-Id30string
Calling-Station-Id31string
NAS-Identifier32string
Proxy-State33string
Login-LAT-Service34string
Login-LAT-Node35string
Login-LAT-Group36string
Framed-AppleTalk-Link37uint32
Framed-AppleTalk-Network38uint32
Framed-AppleTalk-Zone39string
Acct-Status-Type40uint32
Acct-Delay-Time41uint32
Acct-Input-Octets42uint32
Acct-Output-Octets43uint32
Acct-Session-Id44string
Acct-Authentic45uint32
Acct-Session-Time46uint32
Acct-Input-Packets47uint32
Acct-Output-Packets48uint32
Acct-Terminate-Cause49uint32
Acct-Multi-Session-Id50string
Acct-Link-Count51uint32
Acct-Input-Gigawords52uint32
Acct-Output-Gigawords53uint32
Event-Timestamp55uint32
CHAP-Challenge60string
NAS-Port-Type61uint32
Port-Limit62uint32
Login-LAT-Port63string
Tunnel-Type32uint32
Tunnel-Medium-Type65uint32
Tunnel-Client-Endpoint66string
Tunnel-Server-Endpoint67string
Acct-Tunnel-Connection68string
Tunnel-Password69string
ARAP-Password70string
ARAP-Features71string
ARAP-Zone-Access72uint32
ARAP-Security73uint32
ARAP-Security-Data74string
Password-Retry75uint32
Prompt76uint32
Connect-Info77string
Configuration-Token78string
EAP-Message79string
Message-Authenticator80string
Tunnel-Private-Group-ID81string
Tunnel-Assignment-ID82string
Tunnel-Preference83uint32
ARAP-Challenge-Response84string
Acct-Interim-Interval85uint32
Acct-Tunnel-Packets-Lost86uint32
NAS-Port-Id87string
Framed-Pool88string
Tunnel-Client-Auth-ID90string
Tunnel-Server-Auth-ID91string
NAS-IPv6-Address95ip_address
Framed-Interface-Id96string
Framed-IPv6-Prefix97ip6_prefix
Login-IPv6-Host98ip_address
Framed-IPv6-Route99string
Framed-IPv6-Pool100string
Error-Cause101uint32
EAP-Key-Name102string
Digest-Response103string
Digest-Realm104string
Digest-Nonce105string
Digest-Response-Auth106string
Digest-Nonce-Count107string
Digest-Entity-Body-Hash108string
Digest-CNonce109string
Digest-Algorithm111string
Digest-URI120string
Digest-QOP121string
Digest-Method122string
Delegated-IPv6-Prefix123ip6_prefix
Operator-Name126string
Location-Information127string
Location-Data128string
Basic-Location-Policy-Rules129string
Extended-Location-Policy-Rules130string
Location-Capable131uint32
Requested-Location-Info132uint32
Framed-Management133uint32
Management-Transport-Protection134uint32
Management-Policy-Id135string
Management-Privilege-Level136uint32
Originating-Line-Info140string
NAS-Filter-Rule150string
Framed-IPv6-Address168ip_address
DNS-Server-IPv6-Address169ip_address
Route-IPv6-Information170string
Delegated-IPv6-Prefix-Pool171string
Stateful-IPv6-Address-Pool172string
Bandwidth-Max-Up197uint32

MikroTik Vendor ID 14988

MikroTik menggunakan Vendor-Id 14988 untuk mengirim attribute spesifik yang mengontrol fitur seperti rate limit, grup PPP, wireless, queue, DHCP option, dan sebagainya. Attribute-attribute ini umumnya dikirim dalam paket Access-Accept dan CoA-Request untuk mengatur perilaku perangkat MikroTik secara dinamis.

Name ID Type
Mikrotik-Recv-Limit1uint32
Mikrotik-Xmit-Limit2uint32
Mikrotik-Group3string
Mikrotik-Wireless-Forward4uint32
Mikrotik-Wireless-Skip-Dot1x5uint32
Mikrotik-Wireless-Enc-Algo6uint32
Mikrotik-Wireless-Enc-Key7string
Mikrotik-Rate-Limit8string
Mikrotik-Realm9string
Mikrotik-Host-IP10ip_address
Mikrotik-Mark-Id11string
Mikrotik-Advertise-URL12string
Mikrotik-Advertise-Interval13uint32
Mikrotik-Recv-Limit-Gigawords14uint32
Mikrotik-Xmit-Limit-Gigawords15uint32
Mikrotik-Wireless-PSK16string
Mikrotik-Total-Limit17uint32
Mikrotik-Total-Limit-Gigawords18uint32
Mikrotik-Address-List19string
Mikrotik-Management-MPKey20string
Mikrotik-Wireless-Comment21string
Mikrotik-Delegated-IPv6-Pool22string
Mikrotik-DHCP-Option-Set23string
Mikrotik-DHCP-Option-Param-Str124string
Mikrotik-DHCP-Option-Param-Str225string
Mikrotik-Wireless-VLANID26uint32
Mikrotik-Wireless-VLANIDType27uint32
Mikrotik-Wireless-MinSignal28string
Mikrotik-Wireless-MaxSignal29string
Mikrotik-Switching-Filter30string
Mikrotik-VRRP-Password31string
Mikrotik-VRRP-Auth-Type32uint32
Mikrotik-Queue-Parent33string
Mikrotik-Queue-Type34string
Mikrotik-Queue-Priority35uint32
Mikrotik-Queue-Burst-Limit36string
Mikrotik-Queue-Burst-Threshold37string
Mikrotik-Queue-Burst-Time38string
Mikrotik-PPP-Encryption39string
Mikrotik-PPP-Compression40string
Mikrotik-PPP-VJ-Compression41uint32
Mikrotik-PPP-MRU42uint32
Mikrotik-PPP-MTU43uint32
Mikrotik-Pool-Name44string
Mikrotik-Pool-Timeout45uint32
Mikrotik-Pool-Idle-Timeout46uint32
Mikrotik-Pool-Used-Address47ip_address
Mikrotik-Pool-Comment48string
Mikrotik-Pool-Disabled49uint32
Mikrotik-Pool-Next-Pool50string
Mikrotik-Pool-Ranges51string
Mikrotik-Pool-Expiry52string
Mikrotik-Service-Name53string
Mikrotik-Caller-ID54string
Mikrotik-Interface55string
Mikrotik-Parent-Queue56string
Mikrotik-Script57string
Mikrotik-Trusted-MAC58string
Mikrotik-Allow-MAC59string
Mikrotik-Max-Logins60uint32
Mikrotik-Cookie61string
Mikrotik-MAC62string
Mikrotik-Minimum-UP63uint32
Mikrotik-Minimum-Down64uint32
Mikrotik-Wireless-CQ65string
Mikrotik-Wireless-Tx-Power66uint32
Mikrotik-Wireless-Rx-Power67uint32
Mikrotik-Wireless-Station-Name68string
Mikrotik-Wireless-Auth-Algo69uint32
Mikrotik-Wireless-WEP-Key70string
Mikrotik-Wireless-WEP-Tx-Key71uint32
Mikrotik-Wireless-WPA-PSK72string
Mikrotik-Wireless-WPA2-PSK73string
Mikrotik-Wireless-802.1x74uint32
Mikrotik-Wireless-802.1x-Username75string
Mikrotik-Wireless-802.1x-Password76string
Mikrotik-Wireless-802.1x-Interim-Update77uint32
Mikrotik-Wireless-802.1x-Session-Timeout78uint32
Mikrotik-Wireless-802.1x-Idle-Timeout79uint32
Mikrotik-Wireless-802.1x-Acct-Interim-Interval80uint32
Mikrotik-Wireless-802.1x-Acct-Session-Id81string
Mikrotik-Wireless-802.1x-Acct-Multi-Session-Id82string
Mikrotik-Wireless-802.1x-Acct-Link-Count83uint32
Mikrotik-Wireless-802.1x-Acct-Input-Octets84uint32
Mikrotik-Wireless-802.1x-Acct-Output-Octets85uint32
Mikrotik-Wireless-802.1x-Acct-Input-Packets86uint32
Mikrotik-Wireless-802.1x-Acct-Output-Packets87uint32
Mikrotik-Wireless-802.1x-Acct-Input-Gigawords88uint32
Mikrotik-Wireless-802.1x-Acct-Output-Gigawords89uint32
Mikrotik-Wireless-802.1x-Acct-Session-Time90uint32
Mikrotik-Wireless-802.1x-Acct-Terminate-Cause91uint32

Microsoft Vendor ID 311

Microsoft menggunakan Vendor-Id 311 untuk mengirim attribute spesifik yang banyak digunakan pada lingkungan Windows, seperti autentikasi MS-CHAP dan MS-CHAPv2, enkripsi MS-MPPE, filter IP, serta attribute pendukung IPv6 dan accounting. Attribute ini umum dijumpai pada NAS yang melayani klien Windows, termasuk VPN, RDP, dan WiFi enterprise.

Name ID Type
MS-CHAP-Response1string
MS-CHAP-Domain2string
MS-CHAP-Error12string
MS-CHAP-CPW-13string
MS-CHAP-CPW-24string
MS-MPPE-Encryption-Policy7uint32
MS-MPPE-Encryption-Types8uint32
MS-MPPE-Recv-Key13string
MS-MPPE-Send-Key14string
MS-CHAP-Challenge11string
MS-CHAP2-Response25string
MS-CHAP2-Success26string
MS-CHAP2-CPW27string
MS-CHAP2-Error29string
MS-Filter22string
MS-Quarantine-IPFilter36string
MS-IPv6-Filter51string
MS-Primary-DNS-Server28ip_address
MS-Secondary-DNS-Server29ip_address
MS-Primary-NBNS-Server30ip_address
MS-Secondary-NBNS-Server31ip_address
MS-RAS-Vendor23uint32
MS-Local-Address32ip_address
MS-Client-IP-Address33ip_address
MS-Server-Name34string
MS-Link-Utilization-Threshold35uint32
MS-Acct-Auth-Type37uint32
MS-Acct-EAP-Type38uint32
MS-Acct-IPv6-Address39ip_address
MS-Acct-IPv6-Input-Octets40uint64
MS-Acct-IPv6-Output-Octets41uint64
MS-Acct-IPv6-Input-Packets42uint64
MS-Acct-IPv6-Output-Packets43uint64
MS-Acct-IPv6-Input-Gigawords44uint32
MS-Acct-IPv6-Output-Gigawords45uint32
MS-IPv6-Filter51string
MS-Acct-Session-Id52string
MS-Acct-Multi-Session-Id53string
MS-Acct-Link-Count54uint32
MS-Routing-Type55uint32
MS-Callback-Number56string
MS-Callback-Id57string
MS-Callback-Type58uint32
MS-Network-Name59string
MS-IPv6-CP-Address60ip_address

Cisco Vendor ID 9

Cisco menggunakan Vendor-Id 9 untuk mengirim attribute spesifik yang banyak digunakan pada perangkat Cisco seperti router, switch, dan firewall. Attribute yang paling populer adalah Cisco-AVPair yang memungkinkan konfigurasi dinamis seperti pengalihan URL, filter ACL, dan pengaturan bandwidth melalui pasangan key-value[citation:1][citation:9].

Name ID Type
Cisco-AVPair1string
Cisco-Account-Info2string
Cisco-Service-Info3string
Cisco-Command-Code4string
Cisco-Control-Info5string
Cisco-User-Info6string
Cisco-Remote-Access-Details7string
Cisco-NAS-Port8string
Cisco-Fax-Account-Id-Origin9string
Cisco-Fax-Message-Id10string
Cisco-Fax-Pages11uint32
Cisco-Fax-Coverage12string
Cisco-Fax-Modem-Time13uint32
Cisco-Fax-Connect-Speed14uint32
Cisco-Fax-Recipient-Count15uint32
Cisco-Fax-Process-Abort-Flag16uint32
Cisco-Disconnect-Cause17uint32
Cisco-Fax-Dsn-Address18string
Cisco-Fax-Dsn-Flag19uint32
Cisco-Fax-Mdn-Address20string
Cisco-Fax-Mdn-Flag21uint32
Cisco-Fax-Auth-Status22uint32
Cisco-Fax-Dsn-Address23string
Cisco-Email-Server-Address24string
Cisco-Email-Server-Ack-Flag25uint32
Cisco-Gateway-Id26string
Cisco-Email-Address27string
Cisco-Email-Ack-Flag28uint32
Cisco-Email-Rcpt-Address29string
Cisco-Email-Rcpt-Ack-Flag30uint32
Cisco-Fax-Abort-Flag31uint32
Cisco-Fax-Dsn-Flag32uint32
Cisco-Fax-Mdn-Flag33uint32
Cisco-Fax-Auth-Status34uint32
Cisco-Fax-Dsn-Address35string
Cisco-Email-Server-Address36string
Cisco-Email-Server-Ack-Flag37uint32
Cisco-Gateway-Id38string
Cisco-Email-Address39string
Cisco-Email-Ack-Flag40uint32
Cisco-Email-Rcpt-Address41string
Cisco-Email-Rcpt-Ack-Flag42uint32
Cisco-Fax-Abort-Flag43uint32
Cisco-Fax-Dsn-Flag44uint32
Cisco-Fax-Mdn-Flag45uint32
Cisco-Fax-Auth-Status46uint32
Cisco-Fax-Dsn-Address47string
Cisco-Email-Server-Address48string
Cisco-Email-Server-Ack-Flag49uint32
Cisco-Gateway-Id50string
Cisco-Email-Address51string
Cisco-Email-Ack-Flag52uint32
Cisco-Email-Rcpt-Address53string
Cisco-Email-Rcpt-Ack-Flag54uint32
Cisco-Fax-Abort-Flag55uint32
Cisco-Fax-Dsn-Flag56uint32
Cisco-Fax-Mdn-Flag57uint32
Cisco-Fax-Auth-Status58uint32
Cisco-Fax-Dsn-Address59string
Cisco-Email-Server-Address60string
Cisco-Email-Server-Ack-Flag61uint32
Cisco-Gateway-Id62string
Cisco-Email-Address63string
Cisco-Email-Ack-Flag64uint32
Cisco-Email-Rcpt-Address65string
Cisco-Email-Rcpt-Ack-Flag66uint32
Cisco-Fax-Abort-Flag67uint32
Cisco-Fax-Dsn-Flag68uint32
Cisco-Fax-Mdn-Flag69uint32
Cisco-Fax-Auth-Status70uint32
Cisco-Fax-Dsn-Address71string
Cisco-Email-Server-Address72string
Cisco-Email-Server-Ack-Flag73uint32
Cisco-Gateway-Id74string
Cisco-Email-Address75string
Cisco-Email-Ack-Flag76uint32
Cisco-Email-Rcpt-Address77string
Cisco-Email-Rcpt-Ack-Flag78uint32
Cisco-Fax-Abort-Flag79uint32
Cisco-Fax-Dsn-Flag80uint32
Cisco-Fax-Mdn-Flag81uint32
Cisco-Fax-Auth-Status82uint32
Cisco-Fax-Dsn-Address83string
Cisco-Email-Server-Address84string
Cisco-Email-Server-Ack-Flag85uint32
Cisco-Gateway-Id86string
Cisco-Email-Address87string
Cisco-Email-Ack-Flag88uint32
Cisco-Email-Rcpt-Address89string
Cisco-Email-Rcpt-Ack-Flag90uint32
Cisco-Fax-Abort-Flag91uint32
Cisco-Fax-Dsn-Flag92uint32
Cisco-Fax-Mdn-Flag93uint32
Cisco-Fax-Auth-Status94uint32
Cisco-Fax-Dsn-Address95string
Cisco-Email-Server-Address96string
Cisco-Email-Server-Ack-Flag97uint32
Cisco-Gateway-Id98string
Cisco-Email-Address99string
Cisco-Email-Ack-Flag100uint32

ZTE Vendor ID 3902

ZTE menggunakan Vendor-Id 3902 untuk mengirim attribute spesifik yang banyak digunakan pada perangkat akses broadband seperti DSLAM, OLT, dan switch. Attribute ini mencakup konfigurasi QoS, rate limit, tunnel, dan DNS untuk klien[citation:10].

Name ID Type
ZTE-Client-DNS-Pri1uint32
ZTE-Client-DNS-Sec2uint32
ZTE-Context-Name4string
ZTE-Tunnel-Max-Sessions21uint32
ZTE-Tunnel-Max-Tunnels22uint32
ZTE-Tunnel-Window24uint32
ZTE-Tunnel-Retransmit25uint32
ZTE-Tunnel-Cmd-Timeout26uint32
ZTE-PPPOE-URL27string
ZTE-PPPOE-MOTM28string
ZTE-Tunnel-Algorithm31uint32
ZTE-Tunnel-Deadtime32uint32
ZTE-Mcast-Send33uint32
ZTE-Mcast-Receive34uint32
ZTE-Mcast-MaxGroups35uint32
ZTE-Access-Type74uint32
ZTE-Usage-Type81uint32
ZTE-Rate-Ctrl-Scr-Down83uint32
ZTE-Rate-Ctrl-Scr-Up89uint32
ZTE-Rate-Ctrl-Burst-Down84uint32
ZTE-Rate-Ctrl-Burst-Up91uint32
ZTE_Rate-Bust-DPIR191uint32
ZTE_Rate-Bust-UPIR192uint32
ZTE-Rate-Ctrl-Burst-Max-Down92uint32
ZTE-Rate-Ctrl-Burst-Max-Up93uint32
ZTE-Qos-Profile-Down82string
ZTE-Qos-Profile-Up94string
ZTE-Priority-Level90uint32
ZTE-Session-Timeout-Type85uint32
ZTE-Rate-Ctrl-PCR86uint32
ZTE-TCP-Syn-Rate88uint32
ZTE-TCP-Limit-Num95uint32
ZTE-TCP-Limit-Mode96uint32
ZTE-IGMP-Service-Profile-Num97uint32
ZTE-PPP-Client-Type(service-type)101uint32
ZTE-Access-Domain151string
ZTE-VPN-ID190string
ZTE-Rate-Ctrl-PBS-Down202uint32
ZTE-Rate-Ctrl-PBS-Up203uint32
ZTE-Rate-Ctrl-SCR-Up-v6228uint32
ZTE-Rate-Ctrl-Burst-Up-v6229uint32
ZTE-Rate-Ctrl-Burst-Max-Up-v6230uint32
ZTE-Rate-Ctrl-PBS-Up-v6231uint32
ZTE-QoS-Profile-Up-v6232string
ZTE-Rate-Ctrl-SCR-Down-v6233uint32
ZTE-Rate-Ctrl-Burst-Down-v6234uint32
ZTE-Rate-Ctrl-Burst-Max-Down-v6235uint32
ZTE-Rate-Ctrl-PBS-Down-v6236uint32
ZTE-QoS-Profile-Down-v6237string
Kembali